Latest Version of Firefox Not Supportive of INB

The latest version of Firefox (version 52) disables Java plugins, which correspondingly means that INB will no longer be functional with version 52 of Firefox. Many users have set internet browsers, like Firefox, to auto-update, which is causing users to not be able to access INB.

If you have updated to latest version of Firefox, and you need to access INB through Firefox, you can install the Extended Support Release version. You can also use Internet Explorer version 11 to access INB. If you have any questions, please contact your technical support or the IT Service Desk at 348-5555.