Security Alert – Update Google Chrome

Multiple vulnerabilities have been discovered in the web browser Google Chrome. These vulnerabilities can be exploited if a user visits, or is redirected to, a specially crafted web page. The most severe of these vulnerabilities could allow an attacker to execute arbitrary code in the context of the browser, obtain sensitive information, bypass security restrictions and perform unauthorized actions, or cause denial-of-service conditions.

All Google Chrome versions prior to 67.0.3396.62 are vulnerable and should be updated.  If you have any questions, please contact the IT Service Desk at 205-348-5555 or itsd@ua.edu.